Email Service provider Outage
Incident Report for ICPC
Update
We are continuing to work on a fix for this issue.
Posted Oct 18, 2024 - 18:59 BST
Update
This issue has been identified and is been actively worked on.

Order processing is also been effected by this issue.
Posted Oct 18, 2024 - 18:00 BST
Identified
This issue has been identified and is been actively worked on.
Posted Oct 11, 2024 - 17:48 BST
This incident affects: Customer Service Systems.